Platform: Asus U81A notebook computer, Win7 64-bit

Problem: The built-in card reader works ok the first time a card is inserted. But after ejecting the card, the card reader cannot be used again until after rebooting the computer. If the computer is not rebooted and a card is (re-)inserted, the system makes a deep-toned (~"ga-dunk") problem noise, and the drive is not detected.

Notes:
With a card inserted into the drive (the first time), the Device Manager included the following entries:
"USB Disk" (under "Disk Drives")
   Driver details:
     c:\windows\system32\DRIVERS\disk.sys
     c:\windows\system32\DRIVERS\partmgr.sys

"E:\" (under "Portable Devices")
   Driver details:
     c:\windows\system32\DRIVERS\UMDF\WpdFs.dll ver. 6.1.7600.16385 (win7_rtm.090713-1255)
     c:\windows\system32\DRIVERS\WUDFRd.sys ver. 6.2.9200.16384 (win8_rtm.120725-1247)

Windows indicated that the drivers for both of the above items were up to date.

Solution:
Programs and Features included an entry for "Alcor Micro USB Card Reader" (version 1.2.17.25001). I uninstalled this item and rebooted.

After rebooting, I inserted a card into the reader. Windows automatically re-installed the device driver software and indicated that the install was successful.

After doing this, I am able to eject and re-insert the card multiple times, and to read files from it without a problem.

Notes:
After doing the above, the Device Manager includes the same entries and driver versions as before. The only difference is that the item under "Disk Drives" is now named "Multiple Card Reader USB Device" rather than "USB Disk".

Profile

djinncoyote

September 2017

S M T W T F S
     1 2
3456789
10111213141516
17181920212223
24252627282930

Syndicate

RSS Atom

Most Popular Tags

Active Entries

Style Credit

Expand Cut Tags

No cut tags